Welcome to www.linknewnet.com.

New Promotion

-8%
Cisco Switch Catalyst 9500 Series C9500-40X-A
$6350 $5850
-29%
Cisco Catalyst 9300 Series Switch C9300-24T-A
$1750 $1250
-31%
Cisco MDS 9200 Series Switch DS-C9250I-K9
$1600 $1100
-38%
Cisco Catalyst 2960 Series Switch WS-C2960L-48PQ-LL
$800 $500
-42%
Cisco ASR 9001 Series Power Supply A9K-750W-AC
$600 $350

One scenario that takes care of the H3C switch Voice Vlan configuration!
Mar 04 , 2024 206

As voice technology continues to advance, the range of applications for voice devices is expanding. Especially in campus networks, there are both voice data and service data traffic. Generally speaking, voice data needs to have a higher priority than service data in order to reduce the delay and packet loss problems that may occur during transmission.


To meet this demand, enterprises need to introduce voice VLANs (Voice VLANs), which are dedicated to managing the voice data flow of users. The system prioritizes voice data messages and ensures call quality by dividing ports connected to voice devices into voice VLANs and automatically adjusting the QoS (Quality of Service) parameters of voice messages.

H3C Vlan configuration.png

As a network device with excellent performance, H3C switch not only has a good reputation in the market and a wide user base, but also performs well in a variety of use environments. So, when the H3C switch needs to be configured with Voice VLAN, what configuration steps are needed to realize it? Let's take a look.


Note: This case applies to switches such as S5120-52P-LI, S5120-28P-SI, S5120-48P-EI, and other switches of the S5000PV2 and S5120 series.


Configuration requirements and realized effects


In order to ensure that voice data can be forwarded with priority, it is necessary to distinguish the voice phone and PC addresses, set the voice phone address to 192.168.2 network segment divided into VLAN2, and set the PC address to 192.168.10 network segment divided into VLAN10, and the router acts as a DHCP server to give IP addresses to the voice phone and PC.

Vlan configuration.png

Configuration steps


1. Configure the switch

#Turn on POE to power the phone

system-view

[H3C]interface GigabitEthernet1/0/1

[H3C-GigabitEthernet1/0/1]poe enable

[H3C-GigabitEthernet1/0/1]quit

#Create VLAN2 for phones and VLAN10 for PCs.

[H3C]vlan 2

[H3C-vlan2]quit

[H3C]vlan 10

[H3C-vlan10]quit

#Set the OUI address allowed to pass as MAC address prefix 6ca8-4900-0000, i.e., when the prefix of the message is 6ca8-4900-0000, the device will treat it as a voice message

[H3C]voice vlan mac-address 6ca8-4900-0000 mask ffff-ff00-0000 description avaya

#Set port GigabitEthernet1/0/1 as a Hybrid port and enable the port Voice VLAN function.

[H3C]interface GigabitEthernet 1/0/1

[H3C-GigabitEthernet1/0/1]port link-type hybrid

[H3C-GigabitEthernet1/0/1]voice vlan 2 enable

#Set the vlan to which the PC belongs to vlan10

[H3C-GigabitEthernet1/0/1]port hybrid pvid vlan 10

[H3C-GigabitEthernet1/0/1]port hybrid vlan 10 untagged

[H3C-GigabitEthernet1/0/1]quit

#The device connects to interface 1/0/17 of the dhcp server, allowing VLAN2 and VLAN10 to pass through.

[H3C]interface GigabitEthernet 1/0/17

[H3C-GigabitEthernet1/0/17]port link-type trunk

[H3C-GigabitEthernet1/0/17]port trunk permit vlan 2 10

[H3C-GigabitEthernet1/0/17]quit

#Save Configuration

[H3C]save force


2. Configure the DHCP server

#Create VLAN2, VLAN10 and their corresponding VLAN interfaces, configure the IP address for the virtual interface

system-view

[H3C]vlan 2

[H3C-vlan2]quit

[H3C]vlan 10

[H3C-vlan10]quit

[H3C] interface Vlan-interface 2

[H3C-Vlan-interface2]ip address 192.168.2.1 255.255.255.0

[H3C-Vlan-interface2]quit

[H3C] interface Vlan-interface 10

[H3C-Vlan-interface10]ip address 192.168.10.1 255.255.255.0

[H3C-Vlan-interface2]quit

#The device is connected to interface 1/0/7 of the switch, allowing VLAN2 and VLAN10 to pass through.

[H3C]interface GigabitEthernet 1/0/7

[H3C-GigabitEthernet1/0/7]port link-type trunk

[H3C-GigabitEthernet1/0/7]port trunk permit vlan 2 10

[H3C-GigabitEthernet1/0/7]quit

#Setting the DHCP address pool for phone VLAN2

[H3C]dhcp server ip-pool vlan2

[H3C-dhcp-pool-vlan2]network 192.168.2.0 mask 255.255.255.0

[H3C-dhcp-pool-vlan2]gateway-list 192.168.2.1

[H3C-dhcp-pool-vlan2]quit

#Setting the DHCP address pool for PCVLAN 10

[H3C]dhcp server ip-pool vlan10

[H3C-dhcp-pool-vlan10]network 192.168.10.0 mask 255.255.255.0

[H3C-dhcp-pool-vlan10]gateway-list 192.168.10.1

[H3C-dhcp-pool-vlan10]dns-list 114.114.114.114

[H3C-dhcp-pool-vlan10]quit

#Save Configuration

[H3C]save force


Verification of experimental results


#Check the authentication results on the switch to see if the phone is added to VLAN2

dis mac-address

MAC ADDR                  VLAN ID  STATE           PORT INDEX          AGING TIME(s)

3897-d630-676b  10       Learned               GigabitEthernet1/0/17     AGING

3897-d630-676b  2         Learned               GigabitEthernet1/0/17     AGING

6ca8-4986-6d59  2         Learned               GigabitEthernet1/0/1      AGING

0068-eb95-3683  10       Learned               GigabitEthernet1/0/1      AGING 

#To see if the voice vlan configuration is in effect

dis voice  vlan oui

Oui Address     Mask            Description

0003-6b00-0000  ffff-ff00-0000  Cisco phone

00e0-7500-0000  ffff-ff00-0000  Polycom phone

6ca8-4900-0000  ffff-ff00-0000  avaya

#The default voice vlan defaults to auto (automatic mode)

 dis voice  vlan state

 Maximum of Voice VLANs: 1

 Current Voice VLANs: 1

 Voice VLAN security mode: Security

 Voice VLAN aging time: 1440 minutes

 Voice VLAN enabled port and its mode:

 PORT                        VLAN        MODE        COS        DSCP

 --------------------------------------------------------------------

 GigabitEthernet1/0/1        2           AUTO        6          46


The above is the configuration steps of H3C switch on Voice Vlan, have you learned it?


Overall, H3C switches have a worldwide reputation for being suitable for a variety of network environments of different sizes and complexities. Whether it's an efficient small or medium-sized business, a large enterprise, or a carrier-grade network, H3C switches are able to provide, and stabilize, network connectivity. Its product line also covers a wide range of scenarios from ordinary offices to data centers, meeting the needs of different users. If you have other questions about network equipment, it is recommended to consult a professional IT hardware equipment supplier, such as NetDuCom. They will bring you more detailed solutions.

 


Related Blogs

WhatsApp
Quote
Contact
Top